当前位置: > 故障解决 > 常用软件问题 >

解决编译apache (httpd2.4.12)时报错,APR not found

时间:2015-06-15 14:55来源:blog.51cto.com 作者:华荣的技术博客 举报 点击:

在一次编译apache (httpd2.4.12)时报错,APR not found

在apr.apache.org网站上可以下载此软件(apr-1.5.2.tar.gz);apr-util-1.5.4.tar.gz ;

1.解决apr not found问题

[root@websrv tools]# cd /home/huarong/tools/apr-1.5.2

[root@websrv apr-1.5.2]# ./configure --prefix=/usr/local/apr

[root@websrv apr-1.5.2]#make ; make install

2.解决APR-util not found问题

[root@websrv apr-util-1.5.4]# tar -zxvf apr-util-1.5.4.tar.gz

[root@websrv apr-util-1.5.4]# ./configure --prefix=/usr/local/apr-util --with-apr=/usr/local/apr/bin/apr-1-config

[root@websrv apr-util-1.5.4]#make ; make install

3  ../configure仍提示APR-util not found,增加--with-apr=/usr/local/apr --with-apr-util=/usr/local/apr-util后出现configure: error: pcre-config for libpcre not found. PCRE is required and available from http://pcre.org/

下载地址:http://ftp.exim.llorien.org/pcre/

[root@websrv pcre]# tar zxvf pcre-8.10.tar.gz

[root@websrv pcre]# cd pcre-8.10

[root@websrv pcre]# ./configure --prefix=/usr/local/pcre

[root@websrv pcre]# make ; make install

4.编译Apache

[root@websrv ~]# ./configure --prefix=/application/apache2.4.12 --enable-default --enable-expires --enable-headers --enable-modules=most --enable-so --with-mpm=worker --enable-rewrite --with-apr=/home/huarong/tools/apr-1.5.2 --with-apr-util=/home/huarong/tools/apr-util-1.5.4 --with-pcre=/usr/local/pcre/

问题解决。

发表评论
为了和诣的生活,我关闭了评论页面,请大家到QQ群里交流吧:348944156,也欢迎关注本站微信公众号:centoscn
推荐内容