当前位置: > 故障解决 > 常用软件问题 >

RHEL使用yum安装报文件需要更新的错误提示的解决办法

时间:2017-09-06 23:58来源:blog.csdn.net 作者:rznice的专栏 举报 点击:
 RHEL在使用yum安装的时候报类似下面的错误:
错误:软件包:policycoreutils-python-2.2.5-20.el7.x86_64 (docker)
          需要:policycoreutils = 2.2.5-20.el7
          已安装: policycoreutils-2.5-8.el7.x86_64 (@anaconda/7.3)
              policycoreutils = 2.5-8.el7
错误:软件包:libsemanage-python-2.1.10-18.el7.x86_64 (docker)
          需要:libsemanage = 2.1.10-18.el7
          已安装: libsemanage-2.5-4.el7.x86_64 (@anaconda/7.3)
              libsemanage = 2.5-4.el7
错误:软件包:7:device-mapper-event-1.02.107-5.el7_2.5.x86_64 (docker)
          需要:device-mapper = 7:1.02.107-5.el7_2.5
          已安装: 7:device-mapper-1.02.135-1.el7.x86_64 (@anaconda/7.3)
              device-mapper = 7:1.02.135-1.el7
          可用: 7:device-mapper-1.02.107-5.el7_2.5.x86_64 (docker)
              device-mapper = 7:1.02.107-5.el7_2.5
错误:软件包:7:lvm2-2.02.130-5.el7_2.5.x86_64 (docker)
          需要:device-mapper-persistent-data >= 0.5.5-1
错误:软件包:audit-libs-python-2.4.1-5.el7.x86_64 (docker)
          需要:audit-libs = 2.4.1-5.el7
          已安装: audit-libs-2.6.5-3.el7.x86_64 (@anaconda/7.3)
              audit-libs = 2.6.5-3.el7
 您可以尝试添加 --skip-broken 选项来解决该问题
    主机不能上网,经过测试发现是由于yum源找不到造成的,将iso挂在本地镜像文件,配置好本地源重新安装即可。

    本地源镜像文件cdrom.repo:
[cdrom]
name=cdrom-source
baseurl=file:///mnt/iso
gpgcheck=0
enabled=1
    将/dev/cdrom挂在到/mnt/iso上。
    或者使用网络源也可以。
------分隔线----------------------------
发表评论
为了和诣的生活,我关闭了评论页面,请大家到QQ群里交流吧:348944156,也欢迎关注本站微信公众号:centoscn
推荐内容