当前位置: > CentOS教程 > 软件安装教程 >

CentOS 7安装Chrome浏览器

时间:2016-04-20 01:01来源:blog.csdn.net 作者:BetterWorld的专栏 举报 点击:

PROBLEN

从google官方网站上下载rpm安装包。然后安装已经下载好的Chrome rpm安装包报错。

rpm -ivh google-chrome-stable_current_x86_64.rpm 
  • 1
  • 2
  • 1
  • 2
error: Failed dependencies:
    lsb >= 4.0 is needed by google-chrome-stable-50.0.2661.75-1.x86_64
    libXss.so.1()(64bit) is needed by google-chrome-stable-50.0.2661.75-1.x86_64
  • 1
  • 2
  • 3
  • 1
  • 2
  • 3

REASON

缺少相应依赖包。lsb相关与libXss相关。

SOLUTION

安装缺少的依赖包。有一种冒险尝试的方法,即不去看包的依赖关系与缘由,傻瓜式搜索名称相似的包安装上。

yum install *lsb* -y
yum install libXss*  -y
  • 1
  • 2
  • 1
  • 2

安装的包会比较多。大多数情况下能解决问题。  此处具体解决方法:

yum install pax*
yum install redhat-lsb*  -y
yum install libXss*  -y
  • 1
  • 2
  • 3
  • 1
  • 2
  • 3

运行了前两条然而并没有起到作用。最后一条是自己猜着蒙了一把。居然解决了问题。  参考文档  http://3385787.blog.51cto.com/3375787/742142

RESULT


------分隔线----------------------------
发表评论
为了和诣的生活,我关闭了评论页面,请大家到QQ群里交流吧:348944156,也欢迎关注本站微信公众号:centoscn